One X3 Camera Stalls on Capture Screen

Userlevel 2

I’ve been having trouble with the One X3 cameras stalling on the capturing screen just after finishing a walk. Has anyone else experienced this issue? Has anyone found a solution to the problem? 

I have all software and firmware updated and the camera is still having problems. 

My only solution right now is to supply my field with the more expensive RS One cameras since the X2’s have been discontinued.

Also, this issue isn’t just one camera, it seems to be the majority of the X3’s that I have.


Best answer by David_Smith 8 June 2023, 14:37

View original

5 replies


Hi David, thank you for sharing on our Community page. We are sorry to hear you have been experiencing problems with the insta360 OneX3 cameras. 

Some possible solutions that we’ve experienced help resolve this issue:

  1. Turn off the camera, remove the X3 battery for about 30-40 seconds, sign out or force close the app, restart both devices and then sign back in the app.  
  2. If you have no pending video captures to upload, complete a factory reset on the camera. Here is a quick video tutorial.

There has been a recent release of new iOS version 16.5, check if the devices may need to be updated. For Android devices, OS 13 is the latest version.

One of our Support Representatives has reported the issue for you to our Engineering team to further investigate.

Let us know how you go.

Userlevel 2

Hi Paul, 

Thank you for the reply, it’s greatly appreciated. Though, I appologize for any confusion here. I already have a ticket open with support and have been actively working with them on this issue for the past few weeks. 

The main reason for my post was to see if anyone else in the community of OpenSpace users had been having the same issues with the X3’s.

Once again, thank you for the help.

Userlevel 2


  • For apple devices, update the ios to the latest version 16.5. It seems that the previous version ios is what was causing the x3 cameras to hang on the capturing screen.
Userlevel 7

@David_Smith thank you SO MUCH for following up in the Community with your solution! Even though you were also working with our Support team directly, posting the solution that ultimately worked for you in the Community will help users who may run into the same issue in the future get to the solution more quickly 👏😄

Userlevel 2

I’m writing to update the solution for this issue. Within a week of updating the iOS, the problem arose again and I also started experiencing problems with updating firmware on the cameras as well.

Consolidating the issue into one post:


  • Insta360 X3 camera stalls on the “stopping capture” screen. The screen we see after hitting the stop button to end a 360 video walk. The only way to get out of this is to force quit the app and pull the battery from the camera.
  • Updating firmware via the desktop hangs during file transfer most of the time.
  • When the file transfer doesn’t hang up, the camera will still not update the firmware and goes into a loop of “failure to update” and “restart”.


All of the cameras that were failing here had Gigastone Micro SD cards. Swapping the Gigastone card with a SanDisk corrected the issue. While the specs of each card are the same, they do not perform identically.